about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-04-09T13·03+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-04-09T13·03+0000
commitf7526febe4e60e3da61664a5fb58ff19a5882ded (patch)
treef96acde8e85954fde8c8cfb25fd5c9aaee2d55b0 /scripts/Makefile.am
parent30a6122f8061e8c3ac2d96078b75aafa63101f02 (diff)
* A garbage collector for installed packages. nix-collect-garbage
  doesn't actually delete any packages, it just prints their
  descriptor hashes.  So we can do

    nix info $(nix-collect-garbage)

  to print out the ids of the packages that would be deleted, and

    nix delpkg $(nix-collect-garbage)

  to actually delete them.

Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 4e2eada86b..4140cdf5b3 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,4 +1,4 @@
-bin_SCRIPTS = nix-generate-regscript nix-switch
+bin_SCRIPTS = nix-generate-regscript nix-switch nix-collect-garbage
 
 install-exec-local:
 	$(INSTALL) -d $(sysconfdir)/profile.d