about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-01-12T15·17+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-01-12T15·17+0000
commite4d4969ae929682aea936e035cc24d56949a82ba (patch)
tree1fcddffde869e004096673698a5e18ca87049c2a /scripts/Makefile.am
parent5b527901ae625675f525dd65b82f90bcb2001afd (diff)
* New tools nix-pack-closure and nix-unpack-closure. These provide a
  useful way to transfer the closure of a store path to another
  machine.

  These commands provide functionality previously possible through
  `nix-push --copy'.  However, they are much more convenient in many
  situations (though possibly less efficient).
  
  Example:
  $ nix-pack-closure /nix/store/hj232g1r...-subversion-1.3.0 > svn.closure
  (on another machine:)
  $ nix-unpack-closure < svn.closure

  Note that Subversion is added to the store, but not installed into a
  user environment.  One should do `nix-env -i
  /nix/store/hj232g1r...-subversion-1.3.0' for that.

  Another example: copy the application Azureus to the machine
  `scratchy' through ssh:
  
  $ nix-pack-closure $(which azureus) | ssh scratchy nix-unpack-closure


Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 740110d4c1..428d3fa698 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,6 +1,7 @@
 bin_SCRIPTS = nix-collect-garbage \
   nix-pull nix-push nix-prefetch-url \
-  nix-install-package nix-channel nix-build
+  nix-install-package nix-channel nix-build \
+  nix-pack-closure nix-unpack-closure
 
 noinst_SCRIPTS = nix-profile.sh generate-patches.pl
 
@@ -23,4 +24,5 @@ EXTRA_DIST = nix-collect-garbage.in \
   readmanifest.pm.in \
   nix-build.in \
   download-using-manifests.pl.in \
-  generate-patches.pl.in
+  generate-patches.pl.in \
+  nix-pack-closure.in nix-unpack-closure.in