about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-12-30T20·09+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-12-30T20·09+0000
commit94175e978a87a79f3362879898dc1cf7d08d7791 (patch)
tree19bd6e4c73447a886b1915475ac61fa4bcbc541f /scripts/Makefile.am
parent68f2fadb788f8d401fad6fd1db1cfac283e5e337 (diff)
* RPM spec file.
* Respect DESTDIR variable.

Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 1662e99c1c..65d9a4fd81 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -7,13 +7,13 @@ noinst_SCRIPTS = nix-profile.sh
 nix-pull nix-push: readmanifest.pm
 
 install-exec-local: readmanifest.pm
-	$(INSTALL) -d $(sysconfdir)/profile.d
-	$(INSTALL_PROGRAM) nix-profile.sh $(sysconfdir)/profile.d/nix.sh
-	$(INSTALL) -d $(libexecdir)/nix
-	$(INSTALL_DATA) readmanifest.pm $(libexecdir)/nix 
-	$(INSTALL) -d $(sysconfdir)/nix
+	$(INSTALL) -d $(DESTDIR)$(sysconfdir)/profile.d
+	$(INSTALL_PROGRAM) nix-profile.sh $(DESTDIR)$(sysconfdir)/profile.d/nix.sh
+	$(INSTALL) -d $(DESTDIR)$(libexecdir)/nix
+	$(INSTALL_DATA) readmanifest.pm $(DESTDIR)$(libexecdir)/nix 
+	$(INSTALL) -d $(DESTDIR)$(sysconfdir)/nix
 # !!! don't overwrite local modifications
-	$(INSTALL_DATA) prebuilts.conf $(sysconfdir)/nix/prebuilts.conf
+	$(INSTALL_DATA) prebuilts.conf $(DESTDIR)$(sysconfdir)/nix/prebuilts.conf
 
 include ../substitute.mk