about summary refs log tree commit diff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorMichel Alexandre Salim <michel@sylvestre.me>2012-05-27T09·34+0700
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-05-31T12·59-0400
commit6a214f3e06fa1c5f0a4d40e555f14d87691af297 (patch)
tree82f8e4c150e052267cb1fa45e42136adb101c5bb /scripts/Makefile.am
parentd0308073c35799cce98bc853eba64f3922fadcfd (diff)
Update nix profile: - incorporate NixOS's configuration so that nix is usable by normal users - install as a data file, not a program file
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index a5703760d1f7..18a59dbdb6f6 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -11,7 +11,7 @@ nix-pull nix-push: download-using-manifests.pl
 
 install-exec-local: download-using-manifests.pl copy-from-other-stores.pl find-runtime-roots.pl
 	$(INSTALL) -d $(DESTDIR)$(sysconfdir)/profile.d
-	$(INSTALL_PROGRAM) nix-profile.sh $(DESTDIR)$(sysconfdir)/profile.d/nix.sh
+	$(INSTALL_DATA) nix-profile.sh $(DESTDIR)$(sysconfdir)/profile.d/nix.sh
 	$(INSTALL) -d $(DESTDIR)$(libexecdir)/nix
 	$(INSTALL_PROGRAM) find-runtime-roots.pl $(DESTDIR)$(libexecdir)/nix 
 	$(INSTALL_PROGRAM) build-remote.pl $(DESTDIR)$(libexecdir)/nix