about summary refs log tree commit diff
path: root/scratch/haskell-programming-from-first-principles/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-06-18T10·08+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-06-18T10·08+0100
commit362a31166d058b6ad6a7b44f8c52fe2436f0738e (patch)
tree35992576e60b06c0bf39a28b770cd611632c4b81 /scratch/haskell-programming-from-first-principles/shell.nix
parenta981bb0d4a6e0e4d7aadc4a650e2f700c992d2cf (diff)
Create Nix shell for Haskell scratchpad
Helps me run my chapter exercises.
Diffstat (limited to 'scratch/haskell-programming-from-first-principles/shell.nix')
-rw-r--r--scratch/haskell-programming-from-first-principles/shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/scratch/haskell-programming-from-first-principles/shell.nix b/scratch/haskell-programming-from-first-principles/shell.nix
new file mode 100644
index 0000000000..3190e6e75e
--- /dev/null
+++ b/scratch/haskell-programming-from-first-principles/shell.nix
@@ -0,0 +1,10 @@
+let
+  pkgs = import <unstable> {};
+in pkgs.mkShell {
+  buildInputs = with pkgs; [
+    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
+      hpkgs.quickcheck-simple
+      hpkgs.checkers
+    ]))
+  ];
+}