about summary refs log tree commit diff
path: root/scratch/haskell-programming-from-first-principles/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-18T11·00+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commit0c71fc9d1d49daa914c0f56f4f9201d40415d9b4 (patch)
tree3c8a4b894065e64111c20d06026b63db17259c65 /scratch/haskell-programming-from-first-principles/shell.nix
parent51ec9e0d88b15276ec0891f932f6b572d6450809 (diff)
Drop support for dir-locals.nix, <nixpkgs>, etc.
In the spirit of Marie Kondo, I'm tidying up!

TL;DR:
- Prefer .envrc `use_nix` and delete all dir-locals.nix files
- Remove ~all references to <nixpkgs>, <unstable>, <depot> and prefer
  referencing each with briefcase.third_party.{pkgs,unstable,depot}
- Delete nixBufferFromShell function since I was only using that in
  dir-locals.nix files
Diffstat (limited to 'scratch/haskell-programming-from-first-principles/shell.nix')
-rw-r--r--scratch/haskell-programming-from-first-principles/shell.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/scratch/haskell-programming-from-first-principles/shell.nix b/scratch/haskell-programming-from-first-principles/shell.nix
index 3190e6e75e72..b594a4207e48 100644
--- a/scratch/haskell-programming-from-first-principles/shell.nix
+++ b/scratch/haskell-programming-from-first-principles/shell.nix
@@ -1,10 +1,8 @@
 let
-  pkgs = import <unstable> {};
-in pkgs.mkShell {
-  buildInputs = with pkgs; [
-    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
-      hpkgs.quickcheck-simple
-      hpkgs.checkers
-    ]))
+  briefcase = import <briefcase> {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: with hpkgs; [
+    quickcheck-simple
+    checkers
   ];
 }