about summary refs log tree commit diff
path: root/scratch/deepmind/part_two/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-18T11·00+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-20T10·26+0100
commit0c71fc9d1d49daa914c0f56f4f9201d40415d9b4 (patch)
tree3c8a4b894065e64111c20d06026b63db17259c65 /scratch/deepmind/part_two/shell.nix
parent51ec9e0d88b15276ec0891f932f6b572d6450809 (diff)
Drop support for dir-locals.nix, <nixpkgs>, etc.
In the spirit of Marie Kondo, I'm tidying up!

TL;DR:
- Prefer .envrc `use_nix` and delete all dir-locals.nix files
- Remove ~all references to <nixpkgs>, <unstable>, <depot> and prefer
  referencing each with briefcase.third_party.{pkgs,unstable,depot}
- Delete nixBufferFromShell function since I was only using that in
  dir-locals.nix files
Diffstat (limited to 'scratch/deepmind/part_two/shell.nix')
-rw-r--r--scratch/deepmind/part_two/shell.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/scratch/deepmind/part_two/shell.nix b/scratch/deepmind/part_two/shell.nix
index 65de884696..6080171bb8 100644
--- a/scratch/deepmind/part_two/shell.nix
+++ b/scratch/deepmind/part_two/shell.nix
@@ -1,5 +1,6 @@
 let
-  pkgs = import <nixpkgs> {};
+  briefcase = import <briefcase> {};
+  pkgs = briefcase.third_party.pkgs;
 in pkgs.mkShell {
   buildInputs = with pkgs; [
     nodejs