about summary refs log tree commit diff
path: root/scratch/brilliant/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-04T15·36+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-04T15·36+0100
commitb1c403f6b913d0ac416efffba8e563ab6a24fa9b (patch)
treebe94457b46c00018f93b3ece1a941efbeb726891 /scratch/brilliant/shell.nix
parentef40622a87b9dad5781d0214b4f68b450b04b100 (diff)
Create small command line program that parses arguments
Before starting my take-home assignment, the instructions advised me to create a
"Hello, world" program in the language of my choice. Since I'm choosing Haskell,
I created this example as my starter boilerplate.
Diffstat (limited to 'scratch/brilliant/shell.nix')
-rw-r--r--scratch/brilliant/shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/scratch/brilliant/shell.nix b/scratch/brilliant/shell.nix
new file mode 100644
index 000000000000..58a2e9a6a573
--- /dev/null
+++ b/scratch/brilliant/shell.nix
@@ -0,0 +1,9 @@
+let
+  pkgs = import /home/wpcarro/nixpkgs {};
+in pkgs.mkShell {
+  buildInputs = with pkgs; [
+    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
+      optparse-applicative
+    ]))
+  ];
+}