about summary refs log tree commit diff
path: root/scratch/brilliant/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-12T11·03+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-12T11·03+0100
commitbba3f16c43d9cad6ec92cbdfbfe69703701319bc (patch)
treedf1a9be753c67ae46763bc57b95ab838100a9cd6 /scratch/brilliant/shell.nix
parentf11b91c985f95b585820200d0bca5b043fb9f887 (diff)
Prefer snake-shift instead of a row-by-row shift
Per the assignment's instructions, the `Shift n` operation should treat
the *entire keyboard* like a cycle and shift that. I was erroneously
treating *each row* like a cycle and shifting those one-by-one.

This change fixes that. In addition, it also:
- Updates README.md with expected inputs and outputs
- Updates test suite
- Adds `split` dependency to {default,shell}.nix
Diffstat (limited to 'scratch/brilliant/shell.nix')
-rw-r--r--scratch/brilliant/shell.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/scratch/brilliant/shell.nix b/scratch/brilliant/shell.nix
index 02d69d3be01b..d0a6c7e5e6f5 100644
--- a/scratch/brilliant/shell.nix
+++ b/scratch/brilliant/shell.nix
@@ -10,6 +10,7 @@ in pkgs.mkShell {
       hspec
       optparse-applicative
       unordered-containers
+      split
     ]))
   ];
 }