about summary refs log tree commit diff
path: root/scratch/brilliant/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-12T09·28+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-12T09·28+0100
commit3d6130c7cfb31d3a5eb5510d3aec55000b7df230 (patch)
treea4d1a9aa154e4afae493d7b7636aea8033b84f91 /scratch/brilliant/shell.nix
parent17e1764ef8cfa7ebf6b8f1c6b4d4f6edd335e10d (diff)
Provide more useful instructions for building this project
TL;DR:
- include a default.nix to allow users to build an named executable
- emphasize in the README that the user needs Nix to build this project
- pin nixpkgs to a specific commit and fetch it from GitHub
Diffstat (limited to 'scratch/brilliant/shell.nix')
-rw-r--r--scratch/brilliant/shell.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/scratch/brilliant/shell.nix b/scratch/brilliant/shell.nix
index be1ecf3ca77f..02d69d3be01b 100644
--- a/scratch/brilliant/shell.nix
+++ b/scratch/brilliant/shell.nix
@@ -1,5 +1,9 @@
 let
-  pkgs = import /home/wpcarro/nixpkgs {};
+  pkgs = import (builtins.fetchGit {
+    url = "https://github.com/NixOS/nixpkgs-channels";
+    ref = "nixos-20.03";
+    rev = "afa9ca61924f05aacfe495a7ad0fd84709d236cc";
+  }) {};
 in pkgs.mkShell {
   buildInputs = with pkgs; [
     (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [