about summary refs log tree commit diff
path: root/scratch/brilliant/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-12T11·03+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-12T11·03+0100
commitbba3f16c43d9cad6ec92cbdfbfe69703701319bc (patch)
treedf1a9be753c67ae46763bc57b95ab838100a9cd6 /scratch/brilliant/default.nix
parentf11b91c985f95b585820200d0bca5b043fb9f887 (diff)
Prefer snake-shift instead of a row-by-row shift
Per the assignment's instructions, the `Shift n` operation should treat
the *entire keyboard* like a cycle and shift that. I was erroneously
treating *each row* like a cycle and shifting those one-by-one.

This change fixes that. In addition, it also:
- Updates README.md with expected inputs and outputs
- Updates test suite
- Adds `split` dependency to {default,shell}.nix
Diffstat (limited to 'scratch/brilliant/default.nix')
-rw-r--r--scratch/brilliant/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/scratch/brilliant/default.nix b/scratch/brilliant/default.nix
index 83c62a3d2eba..5a0ece741764 100644
--- a/scratch/brilliant/default.nix
+++ b/scratch/brilliant/default.nix
@@ -5,9 +5,10 @@ let
     rev = "afa9ca61924f05aacfe495a7ad0fd84709d236cc";
   }) {};
 
-  ghc = pkgs.haskellPackages.ghcWithPackages (hpkgs: [
-    hpkgs.optparse-applicative
-    hpkgs.unordered-containers
+  ghc = pkgs.haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
+    optparse-applicative
+    unordered-containers
+    split
   ]);
 in pkgs.stdenv.mkDerivation {
   name = "transform-keyboard";