about summary refs log tree commit diff
path: root/rfcToKindle/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-02T18·32+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-02-02T18·54+0000
commit916e46d7ceafaf7584c80851553a0f673fc9d1b9 (patch)
tree0b73212fe3e9d5229abc34170169aef4ef12b6db /rfcToKindle/default.nix
parent4de3e5c39286553df5946327681d0fb814ae235b (diff)
Support script to download RFCs to my Kindle
Today I learned that you can email your Kindle files to read them using the
paperwhite display. I'm attempting to read RFCs, so after reading 1/4 of the way
through RFC6479 (on OAuth2.0), I realized that it might be easier to read on my
Kindle instead of on my computer screen. Out of this, rfcToKindle.go was born.

I'm not sure if I'd like to publish this or not.
Diffstat (limited to 'rfcToKindle/default.nix')
-rw-r--r--rfcToKindle/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/rfcToKindle/default.nix b/rfcToKindle/default.nix
new file mode 100644
index 000000000000..3bfa71f2896d
--- /dev/null
+++ b/rfcToKindle/default.nix
@@ -0,0 +1,13 @@
+{
+  depot ? import <depot> {}, ...
+}:
+
+# TODO: This doesn't depend on `sendgmr` at the moment, but it should. As such,
+# it's an imcomplete packaging.
+depot.buildGo.program {
+  name = "rfcToKindle";
+  srcs = [
+    ./main.go
+  ];
+  deps = [];
+}