about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-01-11T15·30+0100
committerEelco Dolstra <edolstra@gmail.com>2019-01-11T15·33+0100
commit4ae6e849015fb269414c1544e815aba75085cf7b (patch)
treeb74ca4e240b0969f0ffb2a445577e765e1f5e87d /release.nix
parent8ce1986611ccf536c939de3feecfefe64f47fc8f (diff)
install: Use base-16 hashes
Issue #2623.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/release.nix b/release.nix
index 415c87da7cb3..27164506752d 100644
--- a/release.nix
+++ b/release.nix
@@ -296,7 +296,7 @@ let
 
           substitute ${./scripts/install.in} $out/install \
             ${pkgs.lib.concatMapStrings
-              (system: "--replace '@binaryTarball_${system}@' $(nix hash-file --type sha256 ${binaryTarball.${system}}/*.tar.bz2) ")
+              (system: "--replace '@binaryTarball_${system}@' $(nix hash-file --base16 --type sha256 ${binaryTarball.${system}}/*.tar.bz2) ")
               [ "x86_64-linux" "i686-linux" "x86_64-darwin" "aarch64-linux" ]
             } \
             --replace '@nixVersion@' ${build.x86_64-linux.src.version}