about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-01-08T09·48+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-01-08T09·48+0100
commit4202b17666d4ccba825e204e142bc7e294a3ec86 (patch)
treec4ac6ec3a09dc9a5445f8623ff26f13333284361 /release.nix
parent10a6aa3ad4b190afd5009b842ae232204ef49913 (diff)
Temporarily do Darwin builds from a different Nixpkgs branch
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index a6a745e27548..293afcc2490e 100644
--- a/release.nix
+++ b/release.nix
@@ -76,7 +76,8 @@ let
 
     build = pkgs.lib.genAttrs systems (system:
 
-      with import <nixpkgs> { inherit system; };
+      # FIXME: temporarily use a different branch for the Darwin build.
+      with import (if system == "x86_64-darwin" then <nixpkgs-darwin> else <nixpkgs>) { inherit system; };
 
       releaseTools.nixBuild {
         name = "nix";
@@ -110,7 +111,8 @@ let
 
     binaryTarball = pkgs.lib.genAttrs systems (system:
 
-      with import <nixpkgs> { inherit system; };
+      # FIXME: temporarily use a different branch for the Darwin build.
+      with import (if system == "x86_64-darwin" then <nixpkgs-darwin> else <nixpkgs>) { inherit system; };
 
       let
         toplevel = builtins.getAttr system jobs.build;