about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-10-29T14·00+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-10-29T14·00+0000
commit3d71c8013efa5d347b9767af54160b3d0fd9127b (patch)
tree9db9d8b6bef3e85b8e2f4e3e5cf96c45ceab3c98 /release.nix
parent14fbf85380b23efcc19c8479b65336fc7275d90b (diff)
* Use pkgconfig to locate the Boehm GC (as suggested by Ludo), if
  --enable-gc is given.

Diffstat (limited to 'release.nix')
-rw-r--r--release.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/release.nix b/release.nix
index a34a202ae5..c89d79a7d4 100644
--- a/release.nix
+++ b/release.nix
@@ -19,7 +19,7 @@ let
 
         buildInputs =
           [ curl bison24 flex2535 perl libxml2 libxslt w3m bzip2
-            tetex dblatex nukeReferences
+            tetex dblatex nukeReferences pkgconfig
           ];
 
         configureFlags = ''
@@ -67,12 +67,12 @@ let
         name = "nix";
         src = tarball;
 
-        buildInputs = [ curl perl bzip2 openssl ];
+        buildInputs = [ curl perl bzip2 openssl pkgconfig boehmgc ];
 
         configureFlags = ''
           --disable-init-state
           --with-bzip2=${bzip2}
-          --with-boehm-gc=${boehmgc}
+          --enable-gc
         '';
       };