about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-04-19T14·51+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-04-19T14·51+0000
commitf3b8833a48472c3545ea8673d687ea9cadcedd61 (patch)
tree3143fb3d27d506864c72770492dcf01d85e21c80 /release.nix
parentefc7a579e880ec15ebe9afc0d8766c85c7d53ec2 (diff)
* Drop the dependency on the ATerm library.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/release.nix b/release.nix
index e9afe9c9e6..3343f86580 100644
--- a/release.nix
+++ b/release.nix
@@ -29,11 +29,8 @@ let
           --with-xml-flags=--nonet
         '';
 
-        # Include the ATerm and Bzip2 tarballs in the distribution.
+        # Include the Bzip2 tarball in the distribution.
         preConfigure = ''
-          stripHash ${aterm.src}
-          cp -pv ${aterm.src} externals/$strippedName
-
           stripHash ${bzip2.src}
           cp -pv ${bzip2.src} externals/$strippedName
 
@@ -77,7 +74,7 @@ let
 
         configureFlags = ''
           --disable-init-state
-          --with-aterm=${aterm} --with-bzip2=${bzip2}
+          --with-bzip2=${bzip2}
         '';
       };
 
@@ -98,7 +95,7 @@ let
 
         configureFlags = ''
           --disable-init-state
-          --with-aterm=${aterm} --with-bzip2=${bzip2}
+          --with-bzip2=${bzip2}
           --enable-static-nix
         '';
       };
@@ -123,7 +120,7 @@ let
 
         configureFlags = ''
           --disable-init-state --disable-shared
-          --with-aterm=${aterm} --with-bzip2=${bzip2}
+          --with-bzip2=${bzip2}
         '';
 
         lcovFilter = ["*/boost/*" "*-tab.*"];