about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-12-10T15·05+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-12-10T15·05+0100
commit20cf0127f5a0cfd417bc7256db23f6eef2ad8141 (patch)
tree969493e770474ea8cd1e46bffddc7790035f7104 /release.nix
parente529823635c8efee0d96a73fb90117ac81040710 (diff)
Include cacert in the binary tarball
This prevents having to fetch Nixpkgs or cacert over http.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/release.nix b/release.nix
index af0e2362ba..a08cf7a96c 100644
--- a/release.nix
+++ b/release.nix
@@ -122,15 +122,16 @@ let
       in
 
       runCommand "nix-binary-tarball-${version}"
-        { exportReferencesGraph = [ "closure" toplevel ];
+        { exportReferencesGraph = [ "closure1" toplevel "closure2" cacert ];
           buildInputs = [ perl ];
           meta.description = "Distribution-independent Nix bootstrap binaries for ${system}";
         }
         ''
-          storePaths=$(perl ${pathsFromGraph} ./closure)
-          printRegistration=1 perl ${pathsFromGraph} ./closure > $TMPDIR/reginfo
+          storePaths=$(perl ${pathsFromGraph} ./closure1 ./closure2)
+          printRegistration=1 perl ${pathsFromGraph} ./closure1 ./closure2 > $TMPDIR/reginfo
           substitute ${./scripts/install-nix-from-closure.sh} $TMPDIR/install \
-            --subst-var-by nix ${toplevel}
+            --subst-var-by nix ${toplevel} \
+            --subst-var-by cacert ${cacert}
           chmod +x $TMPDIR/install
           dir=nix-${version}-${system}
           fn=$out/$dir.tar.bz2