about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-08-24T09·56+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-08-24T09·56+0000
commit955d11aae738f7f9c56c51e8ab2eabdf8732aab1 (patch)
treec6a447018ba865580700e727997bb079aba4a0f4 /release.nix
parent5c5ab2bc12472f63a33cc841dcdc57f1ed8ddea5 (diff)
parentc67eccc26d42bce9496024ac77eaa7e4ff725d01 (diff)
* Sync with the trunk.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/release.nix b/release.nix
index 62ac87da73..589d0f035e 100644
--- a/release.nix
+++ b/release.nix
@@ -1,5 +1,5 @@
-{ nix ? {outPath = ./.; rev = 1234;}
-, nixpkgs ? ../nixpkgs
+{ nixpkgs ? ../nixpkgs
+, nix ? { outPath = ./.; rev = 1234; }
 , officialRelease ? false
 }:
 
@@ -64,7 +64,7 @@ let
     build =
       { system ? "i686-linux" }:
 
-      with import nixpkgs {inherit system;};
+      with import nixpkgs { inherit system; };
 
       releaseTools.nixBuild {
         name = "nix";
@@ -80,7 +80,7 @@ let
 
 
     coverage =
-      with import nixpkgs {};
+      with import nixpkgs { system = "x86_64-linux"; };
 
       releaseTools.coverageAnalysis {
         name = "nix-build";
@@ -143,7 +143,7 @@ let
   makeRPM = 
     system: diskImageFun: prio:
 
-    with import nixpkgs {inherit system;};
+    with import nixpkgs { inherit system; };
 
     releaseTools.rpmBuild rec {
       name = "nix-rpm-${diskImage.name}";
@@ -160,7 +160,7 @@ let
   makeDeb =
     system: diskImageFun: prio:
 
-    with import nixpkgs {inherit system;};
+    with import nixpkgs { inherit system; };
 
     releaseTools.debBuild {
       name = "nix-deb";
@@ -169,7 +169,7 @@ let
       memSize = 1024;
       meta.schedulingPriority = prio;
       configureFlags = "--sysconfdir=/etc";
-      debRequires = ["curl"];
+      debRequires = [ "curl" ];
     };