about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2019-01-21T10·10+0100
committerVincent Ambo <github@tazj.in>2019-01-21T10·25+0100
commit2682d05ffcadc3f594aab883a8ca56667d479780 (patch)
tree0e2cbceefef5658c96d4f5732786f2e143687ca2 /release.nix
parenta53e75741fecc3416c0b6b7e5d5468d8913da48f (diff)
chore(build): Move Nix commit for releases to latest NixOS stable
Updates a few build dependencies, most notably Go to 1.11. The chosen
commit is the current stable `nixos-18.09` tag in nixpkgs-channels.

While doing this I also checked whether it is now possible to remove
the exception for allowing references, but it's not.

Go may in the future gain support for fully reproducible builds, see
for example issue #16860 on their compiler. At that point maybe we can
drop a few settings here.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index fb80a0e420..9b3ff55c10 100644
--- a/release.nix
+++ b/release.nix
@@ -13,8 +13,8 @@
 let pkgs = import ((import <nixpkgs> {}).fetchFromGitHub {
   owner  = "NixOS";
   repo   = "nixpkgs";
-  rev    = "1bc5bf4beb759e563ffc7a8a3067f10a00b45a7d";
-  sha256 = "00gd96p7yz3rgpjjkizp397y2syfc272yvwxqixbjd1qdshbizmj";
+  rev    = "50f41ea2fcf86def32799f75577a4fe5cfd1132e";
+  sha256 = "1q0bxl5nxx1kabqvyzkdw91c5dnwpi2rwsgs5jdmnj7f0qqgdxh8";
 }) {};
 in with pkgs; buildGoPackage rec {
   name = "kontemplate-${version}";