about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-03-19T10·57+0100
committerEelco Dolstra <edolstra@gmail.com>2018-03-19T10·57+0100
commit44a1b6c0264556d2bc7ac312728421342d92490a (patch)
tree72dacbcfa243b27438cecb9fc361ffb850de4ddf /release.nix
parent138af2e554871b83e23f13939314d7b749de2013 (diff)
Fix build on non-x86_64-linux
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index 7db5e20e1e..0dac174acc 100644
--- a/release.nix
+++ b/release.nix
@@ -1,5 +1,5 @@
 { nix ? builtins.fetchGit ./.
-, nixpkgs ? builtins.fetchGit { url = https://github.com/NixOS/nixpkgs.git; ref = "release-18.03"; }
+, nixpkgs ? builtins.fetchGit { url = https://github.com/NixOS/nixpkgs-channels.git; ref = "nixos-18.03"; }
 , officialRelease ? false
 , systems ? [ "x86_64-linux" "i686-linux" "x86_64-darwin" "aarch64-linux" ]
 }:
@@ -55,7 +55,9 @@ let
 
     build = pkgs.lib.genAttrs systems (system:
 
-      with import nixpkgs { inherit system; };
+      let pkgs = import nixpkgs { inherit system; }; in
+
+      with pkgs;
 
       with import ./release-common.nix { inherit pkgs; };