about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorGraham Christensen <graham@grahamc.com>2017-07-09T17·07-0400
committerGraham Christensen <graham@grahamc.com>2017-07-14T16·10-0400
commitfb40d73e23383224fc541911da95a894bbbcc2a4 (patch)
tree53aeedbfc65b6bc8a39bee5624134461b17783e2 /release.nix
parenta0ad8ba12ee26edf0bf5f221b080a61c0d24a874 (diff)
Switch to a fancy multi-user installer on Darwin
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/release.nix b/release.nix
index 86a7350d5e..796591cc16 100644
--- a/release.nix
+++ b/release.nix
@@ -146,10 +146,15 @@ let
           substitute ${./scripts/install-nix-from-closure.sh} $TMPDIR/install \
             --subst-var-by nix ${toplevel} \
             --subst-var-by cacert ${cacert}
+          substitute ${./scripts/install-darwin-multi-user.sh} $TMPDIR/install-darwin-multi-user \
+            --subst-var-by nix ${toplevel} \
+            --subst-var-by cacert ${cacert}
 
           shellcheck -e SC1090 $TMPDIR/install
+          shellcheck -e SC1091,SC2002 $TMPDIR/install-darwin-multi-user
 
           chmod +x $TMPDIR/install
+          chmod +x $TMPDIR/install-darwin-multi-user
           dir=nix-${version}-${system}
           fn=$out/$dir.tar.bz2
           mkdir -p $out/nix-support
@@ -161,7 +166,7 @@ let
             --transform "s,$TMPDIR/install,$dir/install," \
             --transform "s,$TMPDIR/reginfo,$dir/.reginfo," \
             --transform "s,$NIX_STORE,$dir/store,S" \
-            $TMPDIR/install $TMPDIR/reginfo $storePaths
+            $TMPDIR/install $TMPDIR/install-darwin-multi-user $TMPDIR/reginfo $storePaths
         '');