about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-02-01T14·18+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-02-01T14·18+0100
commit844d83352c23db4a3131ac2b11b9ed2af03cdfd6 (patch)
treed689b99ad62cb9187dfdcd593ac7658265ae48ae /release.nix
parent74ca70da3a6d2f110a9dccf15c46422b1b078e3f (diff)
More "make dist" fixes
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/release.nix b/release.nix
index 29bceca7c7..8d395189e2 100644
--- a/release.nix
+++ b/release.nix
@@ -48,14 +48,13 @@ let
         distPhase =
           ''
             runHook preDist
-            make dist-gzip
-            make dist-xz
+            make dist
             mkdir -p $out/tarballs
             cp *.tar.* $out/tarballs
           '';
 
         preDist = ''
-          make install prefix=$out makefiles=doc/manual/local.mk
+          make install docdir=$out/share/doc/nix makefiles=doc/manual/local.mk
 
           make doc/manual/manual.pdf
           cp doc/manual/manual.pdf $out/manual.pdf
@@ -98,6 +97,8 @@ let
 
         makeFlags = "profiledir=$(out)/etc/profile.d";
 
+        preBuild = "unset NIX_INDENT_MAKE";
+
         installFlags = "sysconfdir=$(out)/etc";
 
         doInstallCheck = true;