about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-05-31T13·16+0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-05-31T13·16+0200
commit1b5b654fe25cf7f2219ebe96a943397d683bfa0e (patch)
tree6120022c3939ba41bb3837e2cd835cda95f4e567 /release.nix
parent33664f0e8d91233772e767128ca654ba10b29149 (diff)
Fix OOM in the installer test
http://hydra.nixos.org/build/36462209
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index b94d9d482c29..1da34443dd4f 100644
--- a/release.nix
+++ b/release.nix
@@ -214,13 +214,15 @@ let
         ''
           useradd -m alice
           su - alice -c 'tar xf ${binaryTarball.x86_64-linux}/*.tar.*'
-          mount -t tmpfs none /nix # Provide a writable /nix.
+          mkdir /dest-nix
+          mount -o bind /dest-nix /nix # Provide a writable /nix.
           chown alice /nix
           su - alice -c '_NIX_INSTALLER_TEST=1 ./nix-*/install'
           su - alice -c 'nix-store --verify'
-          su - alice -c 'nix-store -qR ${build.x86_64-linux}'
+          su - alice -c 'PAGER= nix-store -qR ${build.x86_64-linux}'
           mkdir -p $out/nix-support
           touch $out/nix-support/hydra-build-products
+          umount /nix
         ''); # */
 
     tests.evalNixpkgs =