about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-04-21T14·02+0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-04-21T14·08+0200
commitd155d8015578c43953e4a9d1867e49c0b71534d7 (patch)
treebbadff08b737660f6aa44a37e4b46a31a02d1fcb /release.nix
parent1a714952732c56b4735f65dea49d406aacc7c595 (diff)
Move S3BinaryCacheStore from Hydra
This allows running arbitrary Nix commands against an S3 binary cache.

To do: make this a compile time option to prevent a dependency on
aws-sdk-cpp.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/release.nix b/release.nix
index b81571e2d5..9d9923afc5 100644
--- a/release.nix
+++ b/release.nix
@@ -71,7 +71,14 @@ let
         src = tarball;
 
         buildInputs =
-          [ curl perl bzip2 xz openssl pkgconfig sqlite boehmgc ]
+          [ curl perl bzip2 xz openssl pkgconfig sqlite boehmgc
+
+            (aws-sdk-cpp.override {
+              apis = ["s3"];
+              customMemoryManagement = false;
+            })
+
+          ]
           ++ lib.optional stdenv.isLinux libsodium;
 
         configureFlags = ''