about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2016-08-12T13·44-0400
committerShea Levy <shea@shealevy.com>2017-02-07T20·56-0500
commitf7b7df8d1fcb41156fe92ef2ecf5b17074b88446 (patch)
treef82182ef4ca466809089e462e3261bce30055ef4 /release.nix
parent418a837897e597c5dc2eb4e458462bd04b2abde7 (diff)
Add nix-perl package for the perl bindings
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index 7bfde71a6443..b93b64ea923b 100644
--- a/release.nix
+++ b/release.nix
@@ -41,6 +41,7 @@ let
         '';
 
         preConfigure = ''
+          (cd perl ; autoreconf --install --force --verbose)
           # TeX needs a writable font cache.
           export VARTEXFONTS=$TMPDIR/texfonts
         '';
@@ -96,6 +97,32 @@ let
       });
 
 
+    perl = pkgs.lib.genAttrs systems (system:
+
+      let pkgs = import <nixpkgs> { inherit system; }; in with pkgs;
+
+      releaseTools.nixBuild {
+        name = "nix-perl";
+        src = tarball;
+
+        buildInputs =
+          [ (builtins.getAttr system jobs.build) curl bzip2 xz pkgconfig pkgs.perl ]
+          ++ lib.optional stdenv.isLinux libsodium;
+
+	configureFlags = ''
+          --with-dbi=${perlPackages.DBI}/${pkgs.perl.libPrefix}
+          --with-dbd-sqlite=${perlPackages.DBDSQLite}/${pkgs.perl.libPrefix}
+          --with-www-curl=${perlPackages.WWWCurl}/${pkgs.perl.libPrefix}
+        '';
+
+        enableParallelBuilding = true;
+
+	postUnpack = "sourceRoot=$sourceRoot/perl";
+
+        preBuild = "unset NIX_INDENT_MAKE";
+      });
+
+
     binaryTarball = pkgs.lib.genAttrs systems (system:
 
       # FIXME: temporarily use a different branch for the Darwin build.