about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-03-19T00·20+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-03-19T00·20+0100
commitea402a255f9c03a644d256b0d1443a986a2bbebb (patch)
tree027c3f75e32377b1fc725e245b56330046150ae8 /release.nix
parent4b23900ff1568270c9a03ccadc1cbd0b872e4ef7 (diff)
Replace "make check" with "make installcheck"
Ensuring that the tests work from the build tree requires a growing
number of nasty hacks.  The tests also don't verify that the installed
Nix actually works.  Thus, the tests now require "make install" to
have been run.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index cc17bf552c..1e72f80469 100644
--- a/release.nix
+++ b/release.nix
@@ -79,6 +79,12 @@ let
           --with-dbd-sqlite=${perlPackages.DBDSQLite}/lib/perl5/site_perl
           --enable-gc
         '';
+
+        installCheckPhase = ''
+          make installcheck
+        '';
+
+        postPhases = [ "installCheckPhase" ];
       };
 
 
@@ -101,6 +107,12 @@ let
           --with-dbd-sqlite=${perlPackages.DBDSQLite}/lib/perl5/site_perl
         '';
 
+        installCheckPhase = ''
+          make installcheck
+        '';
+
+        postPhases = [ "installCheckPhase" ];
+        
         lcovFilter = [ "*/boost/*" "*-tab.*" ];
 
         # We call `dot', and even though we just use it to