about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2011-10-11T13·06+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2011-10-11T13·06+0000
commit2492914fbcd1d616c89b83fda0ee08551486273e (patch)
tree58f0713bae6389d2e7737a7e93c53681dd27cf10 /release.nix
parentc362e4d718cb31e532a4e2d708d07a57bc3bdf55 (diff)
* Move the remote building test from the NixOS tree to the Nix tree.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index cc210d2c6d..5a64374271 100644
--- a/release.nix
+++ b/release.nix
@@ -1,5 +1,5 @@
-{ nixpkgs ? ../nixpkgs
-, nix ? { outPath = ./.; rev = 1234; }
+{ nixpkgs ? <nixpkgs>, nixos ? <nixos>
+, nix ? { outPath = ../nix-export; rev = 1234; }
 , officialRelease ? false
 }:
 
@@ -140,6 +140,11 @@ let
     deb_ubuntu1010x86_64 = makeDeb_x86_64 (diskImageFuns: diskImageFuns.ubuntu1010x86_64) 50;
 
 
+    # System tests.
+    tests.remote_builds = (import ./tests/remote-builds.nix rec {
+      inherit nixpkgs nixos; nix = build { inherit system; }; system = "x86_64-linux";
+    }).test;
+
   };