about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-08-04T16·00+0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-08-04T16·00+0200
commitd5a076c36f6588366fd9766c1054807bbbfd8559 (patch)
treea22f662fca27e2ae43bf87aa5c81288cd704a538 /release.nix
parent4d73e2e893850d032770373b026854228c61dc8e (diff)
Add option ‘build-extra-chroot-dirs’
This is useful for extending (rather than overriding) the default set
of chroot paths.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/release.nix b/release.nix
index c439257925..bc4c06a0b7 100644
--- a/release.nix
+++ b/release.nix
@@ -98,7 +98,7 @@ let
         preHook = lib.optionalString stdenv.isLinux (
           let sh = stdenv.shell; in
           ''
-            NIX_CFLAGS_COMPILE+=" -DDEFAULT_CHROOT_DIRS=\"/bin/sh=${sh}:$(tr '\n' ':' < ${writeReferencesToFile sh})\""
+            export DEFAULT_CHROOT_DIRS="/bin/sh=${sh} $(tr '\n' ' ' < ${writeReferencesToFile sh})"
           '');
 
         enableParallelBuilding = true;