about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2016-11-09T17·45+0100
committerEelco Dolstra <edolstra@gmail.com>2016-11-09T17·45+0100
commit21c55ab3b54fc2db30ca53c572d24b38331f508c (patch)
tree9c70dbbdeb47dca6eb723f85631b000298abc09b /release.nix
parenta83b10f84c403d0a38439ce0dd2ce8963cc58af7 (diff)
Implement backwards-compatible RemoteStore::addToStore()
The SSHStore PR adds this functionality to the daemon, but we have to
handle the case where the Nix daemon is 1.11.

Also, don't require signatures for trusted users. This restores 1.11
behaviour.

Fixes https://github.com/NixOS/hydra/issues/398.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/release.nix b/release.nix
index d236cdae9b..6b16bc718a 100644
--- a/release.nix
+++ b/release.nix
@@ -25,7 +25,7 @@ let
 
         buildInputs =
           [ curl bison flex perl libxml2 libxslt bzip2 xz
-            pkgconfig sqlite libsodium
+            pkgconfig sqlite libsodium boehmgc
             docbook5 docbook5_xsl
             autoconf-archive
           ] ++ lib.optional (!lib.inNixShell) git;
@@ -34,6 +34,7 @@ let
           --with-dbi=${perlPackages.DBI}/${perl.libPrefix}
           --with-dbd-sqlite=${perlPackages.DBDSQLite}/${perl.libPrefix}
           --with-www-curl=${perlPackages.WWWCurl}/${perl.libPrefix}
+          --enable-gc
         '';
 
         postUnpack = ''