about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorGraham Christensen <graham@grahamc.com>2017-12-12T13·31-0500
committerGraham Christensen <graham@grahamc.com>2017-12-12T13·31-0500
commite4ece83b1aad1bbbdc7cd39d9d0829f85330e505 (patch)
treef037d5599817362db4b248f5c1692cab99ce0357 /release.nix
parent1ca8e9517808198080579a1105d3cf5b4e7ec64c (diff)
tests.setuid: only on i686 and x86_64 linuxs
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/release.nix b/release.nix
index c5c2170f78d0..538211ca9498 100644
--- a/release.nix
+++ b/release.nix
@@ -225,10 +225,12 @@ let
       nix = build.x86_64-linux; system = "x86_64-linux";
     });
 
-    tests.setuid = pkgs.lib.genAttrs (pkgs.lib.filter (pkgs.lib.hasSuffix "-linux") systems) (system:
-      import ./tests/setuid.nix rec {
-        nix = build.${system}; inherit system;
-      });
+    tests.setuid = pkgs.lib.genAttrs
+      (pkgs.lib.filter (system: system == "x86_64-linux" || system == "i686-linux") systems)
+      (system:
+        import ./tests/setuid.nix rec {
+          nix = build.${system}; inherit system;
+        });
 
     tests.binaryTarball =
       with import <nixpkgs> { system = "x86_64-linux"; };