about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2020-02-15T20·48+0100
committerEelco Dolstra <edolstra@gmail.com>2020-02-18T17·02+0100
commitdb3d3a56184a34d7fa46f493e1ecd3ff0ff10453 (patch)
tree1594dc027440a4efd03d1edc1f4d769f77d273fe /release.nix
parent91030eae507db719048c89a8e4542e025261ed5d (diff)
Build with large config Boehm GC
(cherry picked from commit 583d06385de82ab5c7fc77d26cd138d3c6d5f4b5)
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index 2ab6a63f7aef..64aa1a976689 100644
--- a/release.nix
+++ b/release.nix
@@ -23,7 +23,7 @@ let
         src = nix;
         inherit officialRelease;
 
-        buildInputs = tarballDeps ++ buildDeps;
+        buildInputs = tarballDeps ++ buildDeps ++ propagatedDeps;
 
         configureFlags = "--enable-gc";
 
@@ -67,6 +67,8 @@ let
 
         buildInputs = buildDeps;
 
+        propagatedBuildInputs = propagatedDeps;
+
         preConfigure =
           # Copy libboost_context so we don't get all of Boost in our closure.
           # https://github.com/NixOS/nixpkgs/issues/45462
@@ -198,7 +200,9 @@ let
         name = "nix-build";
         src = tarball;
 
-        buildInputs = buildDeps;
+        enableParallelBuilding = true;
+
+        buildInputs = buildDeps ++ propagatedDeps;
 
         dontInstall = false;