about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorDan Peebles <pumpkin@me.com>2016-03-29T00·06-0400
committerDan Peebles <pumpkin@me.com>2016-03-29T00·06-0400
commitc89783b6a7819c46bc00cb40686afdf37cb5e736 (patch)
tree9c8b90ef4bb07a50295a4c96b3c43b4930b08960 /release.nix
parent3b81b2645706d7f8d9c0ec228426dee8ef1fc7ac (diff)
Kill the temporary darwin-specific channel
The issues have been resolved upstream in the main nixpkgs channel now
Diffstat (limited to '')
-rw-r--r--release.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/release.nix b/release.nix
index 79df103ccf..29c6d5a6b7 100644
--- a/release.nix
+++ b/release.nix
@@ -77,8 +77,7 @@ let
 
     build = pkgs.lib.genAttrs systems (system:
 
-      # FIXME: temporarily use a different branch for the Darwin build.
-      with import (if system == "x86_64-darwin" then <nixpkgs-darwin> else <nixpkgs>) { inherit system; };
+      with import <nixpkgs> { inherit system; };
 
       releaseTools.nixBuild {
         name = "nix";
@@ -113,7 +112,7 @@ let
     binaryTarball = pkgs.lib.genAttrs systems (system:
 
       # FIXME: temporarily use a different branch for the Darwin build.
-      with import (if system == "x86_64-darwin" then <nixpkgs-darwin> else <nixpkgs>) { inherit system; };
+      with import <nixpkgs> { inherit system; };
 
       let
         toplevel = builtins.getAttr system jobs.build;