about summary refs log tree commit diff
path: root/release-common.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-03-14T18·11+0100
committerEelco Dolstra <edolstra@gmail.com>2018-03-14T18·25+0100
commitc04bca34016c41d1fcab222e2d61a26a285340c6 (patch)
treee1323fa3c0755065656a8e6c33edb8785950718d /release-common.nix
parentca14b142001ab467e679d4ed0cc6236180bf34b2 (diff)
Factor out commonality between release.nix and shell.nix
Diffstat (limited to 'release-common.nix')
-rw-r--r--release-common.nix40
1 files changed, 38 insertions, 2 deletions
diff --git a/release-common.nix b/release-common.nix
index f9df6fab9f..0c12bc7ceb 100644
--- a/release-common.nix
+++ b/release-common.nix
@@ -1,9 +1,11 @@
 { pkgs }:
 
+with pkgs;
+
 rec {
   # Use "busybox-sandbox-shell" if present,
   # if not (legacy) fallback and hope it's sufficient.
-  sh = pkgs.busybox-sandbox-shell or (pkgs.busybox.override {
+  sh = pkgs.busybox-sandbox-shell or (busybox.override {
     useMusl = true;
     enableStatic = true;
     enableMinimal = true;
@@ -30,7 +32,41 @@ rec {
   configureFlags =
     [ "--disable-init-state"
       "--enable-gc"
-    ] ++ pkgs.lib.optionals pkgs.stdenv.isLinux [
+    ] ++ lib.optionals stdenv.isLinux [
       "--with-sandbox-shell=${sh}/bin/busybox"
     ];
+
+  tarballDeps =
+    [ bison
+      flex
+      libxml2
+      libxslt
+      docbook5
+      docbook5_xsl
+      autoconf-archive
+      autoreconfHook
+    ];
+
+  buildDeps =
+    [ curl
+      bzip2 xz brotli
+      openssl pkgconfig sqlite boehmgc
+      boost
+
+      # Tests
+      git
+      mercurial
+    ]
+    ++ lib.optional stdenv.isLinux libseccomp
+    ++ lib.optional (stdenv.isLinux || stdenv.isDarwin) libsodium
+    ++ lib.optional (stdenv.isLinux || stdenv.isDarwin)
+      (aws-sdk-cpp.override {
+        apis = ["s3"];
+        customMemoryManagement = false;
+      });
+
+  perlDeps =
+    [ perl
+      perlPackages.DBDSQLite
+    ];
 }