about summary refs log tree commit diff
path: root/presentations/bootstrapping-2018/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-06-26T19·38+0100
committertazjin <mail@tazj.in>2020-06-26T19·51+0000
commit2e3b03b5ae04cc9d4da0001aff07962bf4107d42 (patch)
tree75d929acb15720bc8eb1182d105e2ecaa2626ba0 /presentations/bootstrapping-2018/default.nix
parent1d0e421cb86861c64b58d5aa66dce295ffe28af5 (diff)
chore(tazjin): Move my presentations to my user directory r/1090
Change-Id: I72b25680e7167c3a55477111c28b1d4936c60e2c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/606
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'presentations/bootstrapping-2018/default.nix')
-rw-r--r--presentations/bootstrapping-2018/default.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/presentations/bootstrapping-2018/default.nix b/presentations/bootstrapping-2018/default.nix
deleted file mode 100644
index 0dff14b2a1a6..000000000000
--- a/presentations/bootstrapping-2018/default.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-# This derivation builds the LaTeX presentation.
-
-{ pkgs, ... }:
-
-with pkgs;
-
-let tex = texlive.combine {
-  inherit (texlive)
-    beamer
-    beamertheme-metropolis
-    etoolbox
-    euenc
-    extsizes
-    fontspec
-    lualibs
-    luaotfload
-    luatex
-    minted
-    ms
-    pgfopts
-    scheme-basic
-    translator;
-};
-in stdenv.mkDerivation {
-  name = "nuug-bootstrapping-slides";
-  src = ./.;
-
-  FONTCONFIG_FILE = makeFontsConf {
-    fontDirectories = [ fira fira-code fira-mono ];
-  };
-
-  buildInputs = [ tex fira fira-code fira-mono ];
-  buildPhase = ''
-    # LaTeX needs a cache folder in /home/ ...
-    mkdir home
-    export HOME=$PWD/home
-    # ${tex}/bin/luaotfload-tool -ufv
-
-    # As usual, TeX needs to be run twice ...
-    function run() {
-      ${tex}/bin/lualatex presentation.tex
-    }
-    run && run
-  '';
-
-  installPhase = ''
-    mkdir -p $out
-    cp presentation.pdf $out/
-  '';
-}