about summary refs log tree commit diff
path: root/pkgs/terraform-bin.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-04-04T15·10+0200
committerVincent Ambo <tazjin@gmail.com>2018-04-04T15·10+0200
commit01aed568e561f072eeeb9df4c608ce2271e77912 (patch)
tree1f0b607ac4f7f8a4fdf5f7dab0ba03f2be72676c /pkgs/terraform-bin.nix
parent2a6d57e97b04d2e987f317d43389c2cf398df20e (diff)
feat: Update to NixOS 18.03
As the subject says ...

This only includes some minor changes in configuration. Most
interestingly several packages that I used to have in this repository
as custom packages are now available in `nixos-unstable`.

Unfortunately they weren't included in NixOS 18.03 though ...

Either way, this is cleaner.
Diffstat (limited to 'pkgs/terraform-bin.nix')
-rw-r--r--pkgs/terraform-bin.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/pkgs/terraform-bin.nix b/pkgs/terraform-bin.nix
deleted file mode 100644
index a12900d6a3c2..000000000000
--- a/pkgs/terraform-bin.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-# Package to install a Terraform binary release.
-# This is necessary because the Terraform package on Nix does not currently
-# build for some reason.
-
-with import <nixpkgs> {};
-
-stdenv.mkDerivation rec {
-  name = "terraform-${version}";
-  version = "0.10.7";
-
-  src = fetchzip {
-    url = "https://releases.hashicorp.com/terraform/0.10.7/terraform_0.10.7_linux_amd64.zip";
-    sha256 = "189g94bb1d3wxzp720a5vki91czsqmk728469wa1fdkl43cdqd2n";
-  };
-
-  installPhase = ''
-    mkdir -p $out/bin
-    mv terraform $out/bin/terraform
-  '';
-
-  meta = with stdenv.lib; {
-    description = "Terraform is a tool for building, changing, and combining infrastructure safely and efficiently";
-    homepage = "https://www.terraform.io/";
-    license  = licenses.mpl20;
-  };
-}