about summary refs log tree commit diff
path: root/pkgs/terraform-bin.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2017-10-18T13·16+0200
committerVincent Ambo <tazjin@gmail.com>2017-10-18T13·16+0200
commit6118c611c0060c5e46c21c6c7feffa1147d0c138 (patch)
tree5f3e504e2b17a2f138c2c7a3a58405974b31c720 /pkgs/terraform-bin.nix
parentb2585a0bcf45a495d3e69283f9be97e057f457e6 (diff)
feat(pkgs): Add terraform-bin package
The source build of Terraform is currently broken in NixOS.

This adds a binary package.
Diffstat (limited to '')
-rw-r--r--pkgs/terraform-bin.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/terraform-bin.nix b/pkgs/terraform-bin.nix
new file mode 100644
index 000000000000..cb1481df8393
--- /dev/null
+++ b/pkgs/terraform-bin.nix
@@ -0,0 +1,28 @@
+# Package to install a Terraform binary release.
+# This is necessary because the Terraform package on Nix does not currently
+# build for some reason.
+
+with import <nixpkgs> {};
+
+stdenv.mkDerivation rec {
+  name = "terraform-${version}";
+  version = "0.10.7";
+
+  src = fetchzip {
+    url = "https://releases.hashicorp.com/terraform/0.10.7/terraform_0.10.7_linux_amd64.zip";
+    sha256 = "189g94bb1d3wxzp720a5vki91czsqmk728469wa1fdkl43cdqd2n";
+  };
+
+  installPhase = ''
+    mkdir -p $out/bin
+    mv terraform $out/bin/terraform
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Terraform is a tool for building, changing, and combining infrastructure safely and efficiently";
+    homepage = "https://www.terraform.io/";
+    license  = licenses.mpl20;
+  };
+
+  #
+}