about summary refs log tree commit diff
path: root/pkgs/mq-cli.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-04-04T15·10+0200
committerVincent Ambo <tazjin@gmail.com>2018-04-04T15·10+0200
commit01aed568e561f072eeeb9df4c608ce2271e77912 (patch)
tree1f0b607ac4f7f8a4fdf5f7dab0ba03f2be72676c /pkgs/mq-cli.nix
parent2a6d57e97b04d2e987f317d43389c2cf398df20e (diff)
feat: Update to NixOS 18.03
As the subject says ...

This only includes some minor changes in configuration. Most
interestingly several packages that I used to have in this repository
as custom packages are now available in `nixos-unstable`.

Unfortunately they weren't included in NixOS 18.03 though ...

Either way, this is cleaner.
Diffstat (limited to 'pkgs/mq-cli.nix')
-rw-r--r--pkgs/mq-cli.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/pkgs/mq-cli.nix b/pkgs/mq-cli.nix
deleted file mode 100644
index c007b9b479be..000000000000
--- a/pkgs/mq-cli.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-# Build and install mq-cli.
-
-with import <nixpkgs> {};
-
-let
-  # The cached Cargo registry moves *very* slowly, override it:
-  newRegistry = rustRegistry.overrideAttrs (oldAttrs: rec {
-    name = "rustRegistry-2017-10-20";
-    src = fetchFromGitHub {
-      owner  = "rust-lang";
-      repo   = "crates.io-index";
-      rev    = "a1e85af8f57ba61e505c2cb2dc359b66caf355e9";
-      sha256 = "0xcszw287kqlz15ikflsim36mrvpvlb2y074vg22szz0r48nn06v";
-    };
-  });
-in rustPlatform.buildRustPackage rec {
-  name = "mqcli-${version}";
-  version = "0.1.0";
-
-  rustRegistry = newRegistry;
-  depsSha256 = "138a4dgwhf78bnmxz2ibxqz1wifq5046czxd0w8a4gwngy2ryiqs";
-
-  src = fetchFromGitHub {
-    owner  = "aprilabank";
-    repo   = "mq-cli";
-    rev    = "d908fe1cbc7de0bff7cadbe0b3851d50229b7de2";
-    sha256 = "0c4myav65dzks53q4grin9lhcz1jzpddqnihf2h9lm098dhrswkp";
-  };
-
-  meta = with stdenv.lib; {
-    description = "CLI interface to POSIX message queues";
-    homepage    = https://github.com/aprilabank/mq-cli;
-    license     = licenses.mit;
-  };
-}