about summary refs log tree commit diff
path: root/pkg.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2019-08-31T17·15-0400
committerGriffin Smith <root@gws.fyi>2019-08-31T17·15-0400
commit6eba471e2426e7e4e7d5c935e3ce973e13fd6b24 (patch)
treee7b41534bdd6b08fcd8c0e1c5444f3605e66cf09 /pkg.nix
parentd3f3890dc5408581eb6181125c871d1cf2c0e18f (diff)
Use haskellSrc2nix over explicit cabal2nix
Use the (undocumented!) helper function haskellSrc2nix over having to
explicitly run cabal2nix all the time when rebuilding
Diffstat (limited to 'pkg.nix')
-rw-r--r--pkg.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/pkg.nix b/pkg.nix
new file mode 100644
index 0000000000..d3b65a64f3
--- /dev/null
+++ b/pkg.nix
@@ -0,0 +1,7 @@
+{ nixpkgs ? import ./nixpkgs.nix {} }:
+let inherit (nixpkgs) pkgs; in
+import (pkgs.haskellPackages.haskellSrc2nix {
+  name = "xanthous";
+  src = ./.;
+  extraCabal2nixOptions = "--hpack";
+})