about summary refs log tree commit diff
path: root/packages.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2017-10-16T20·53+0200
committerVincent Ambo <tazjin@gmail.com>2017-10-16T20·53+0200
commit202467e9894f4b33186b686d66a4b98a1ac386a8 (patch)
tree0653d7a340e11fc4389d2454999eb3420d4e593c /packages.nix
parentaa5dcbc4777a8e6f42eaee9ac0301d687363e040 (diff)
refactor: Move packages & wallpapers config into own nix files
My systems are single-user machines and the package configuration can
go in the system-wide package list in full.

This splits out the package list into a separate file and also moves
the systemd units for wallpaper setting into a separate file.
Diffstat (limited to 'packages.nix')
-rw-r--r--packages.nix62
1 files changed, 62 insertions, 0 deletions
diff --git a/packages.nix b/packages.nix
new file mode 100644
index 0000000000..83fe2bc119
--- /dev/null
+++ b/packages.nix
@@ -0,0 +1,62 @@
+# This file contains configuration for packages to install.
+# It does not contain configuration for software that is already covered
+# by other NixOS options (e.g. emacs)
+
+{ config, pkgs, ... }:
+
+let unstable = import <nixos-unstable> { config.allowUnfree = true; };
+    rust-overlay = import nixpkgs-mozilla/rust-overlay.nix;
+in {
+  # Configure the Nix package manager
+  nixpkgs.config.allowUnfree = true;
+  nixpkgs.overlays = [ rust-overlay ];
+
+  # ... and declare packages to be installed.
+  environment.systemPackages = with pkgs; [
+    # Default nixos.* packages:
+    alacritty
+    curl
+    direnv
+    exa
+    fd
+    fish
+    gcc
+    git
+    gnumake
+    gnupg
+    htop
+    i3lock
+    jetbrains.idea-community
+    kubernetes
+    lxappearance-gtk3
+    manpages
+    numix-gtk-theme
+    numix-icon-theme
+    openjdk
+    pass
+    pavucontrol
+    ripgrep
+    rofi
+    rofi-pass
+    spotify
+    stdmanpages
+    tdesktop
+    tig
+    tmux
+    tree
+    unzip
+    xclip
+    xfce.xfce4-screenshooter
+
+    # nixos-unstable.* packages:
+    unstable.firefox-beta-bin
+    unstable.numix-cursor-theme
+
+    # Overlay packages:
+    latest.rustChannels.stable.rust
+
+    # Custom packages:
+    (import pkgs/nixfd.nix)
+  ];
+}
+