about summary refs log tree commit diff
path: root/packages.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2018-06-15T11·56+0200
committerVincent Ambo <mail@tazj.in>2018-06-15T11·56+0200
commitb1d45f5b7623f6c67bcb056063e7272c7a58ccaf (patch)
tree7627abfa9c7ac01469676a1c118018fb62a4176b /packages.nix
parent24314a61d6ec0dd138154e789d53c9ce402a4426 (diff)
refactor(emacs): Use unstable channel directly in emacs module
Stores the unstable channel in the global package set to make it
available in the emacs module.

All emacs-related packages are now taken from the unstable channel.

Related changes:

* prescient is now built directly from git
* sly has been (temporarily) removed because the MELPA recipe is
  failing

Unfortunately the version bumps to prescient and ivy (& its related
packages) don't seem to help with raxod502/prescient.el#10
Diffstat (limited to 'packages.nix')
-rw-r--r--packages.nix19
1 files changed, 4 insertions, 15 deletions
diff --git a/packages.nix b/packages.nix
index ea76f3183f22..4804aa8ad859 100644
--- a/packages.nix
+++ b/packages.nix
@@ -33,26 +33,15 @@ in {
     # To use the pinned channel, the original package set is thrown
     # away in the overrides:
     config.packageOverrides = oldPkgs: stable // {
+      # Store whole unstable channel in case that other modules need
+      # it (see emacs.nix for example):
+      inherit unstable;
+
       wallpapers = import ./pkgs/wallpapers.nix;
       pulseaudio-ctl = import pkgs/pulseaudio-ctl.nix;
 
       kontemplate = unstable.kontemplate;
       mq-cli = unstable.mq-cli;
-
-      # Override various Emacs packages from unstable:
-      pinnedEmacs = with unstable.emacsPackagesNg; {
-        inherit
-          counsel
-          counsel-tramp
-          exwm
-          ivy
-          ivy-gitlab
-          ivy-hydra
-          ivy-pass
-          markdown-mode
-          markdown-toc
-          swiper;
-      };
       emacs = unstable.emacs; # emacs 26.1
     };
   };