about summary refs log tree commit diff
path: root/packages.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-03-04T21·08+0100
committerVincent Ambo <tazjin@gmail.com>2018-03-04T21·09+0100
commitbcd317f23df6d076470879c706ca025659bfa722 (patch)
treeea16ddf868e3e1a9fe8b7cc03590833af84b33d9 /packages.nix
parent0937f19408621d950507782772ae6c88777b5bd6 (diff)
refactor(pkgs): Add wallpapers to top-level package set
Diffstat (limited to 'packages.nix')
-rw-r--r--packages.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/packages.nix b/packages.nix
index 27435e545d..4cbe8ba60f 100644
--- a/packages.nix
+++ b/packages.nix
@@ -8,8 +8,13 @@ let unstable = import <nixos-unstable> { config.allowUnfree = true; };
     rust-overlay = import nixpkgs-mozilla/rust-overlay.nix;
 in {
   # Configure the Nix package manager
-  nixpkgs.config.allowUnfree = true;
-  nixpkgs.overlays = [ rust-overlay ];
+  nixpkgs = {
+    overlays = [ rust-overlay ];
+    config.allowUnfree = true;
+    config.packageOverrides = oldPkgs: oldPkgs // {
+      wallpapers = import ./pkgs/wallpapers.nix;
+    };
+  };
 
   # ... and declare packages to be installed.
   environment.systemPackages = with pkgs; [