about summary refs log tree commit diff
path: root/overrides/writeElispBin.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T20·37+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T20·37+0000
commit8de5d093d8e35b2492c81015dcfcb052d2718614 (patch)
treef4bb5763a39c7059537fc7877e3c0ac15a4d8f69 /overrides/writeElispBin.nix
parent03bfe08e1dd9faf48b06cb146bfa446575cde88a (diff)
refactor: Fix a variety of filepaths for repo relayouting r/238
This fixes readTree and the various project builds, as well
as (hopefully) most documentation links inside of the projects.
Diffstat (limited to 'overrides/writeElispBin.nix')
-rw-r--r--overrides/writeElispBin.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/overrides/writeElispBin.nix b/overrides/writeElispBin.nix
deleted file mode 100644
index a1616fb9d4..0000000000
--- a/overrides/writeElispBin.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ pkgs, ... }:
-
-{ name, src, deps ? (_: []), emacs ? pkgs.third_party.emacs26-nox }:
-
-let
-  inherit (pkgs.third_party) emacsPackagesNg emacsPackagesNgGen writeTextFile;
-  inherit (builtins) isString toFile;
-
-  finalEmacs = (emacsPackagesNgGen emacs).emacsWithPackages deps;
-
-  srcFile = if isString src
-    then toFile "${name}.el" src
-    else src;
-in writeTextFile {
-  inherit name;
-  executable = true;
-  destination = "/bin/${name}";
-
-  text = ''
-    #!/bin/sh
-    ${finalEmacs}/bin/emacs --batch --no-site-file --script ${srcFile} $@
-  '';
-}