about summary refs log tree commit diff
path: root/overrides/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-21T12·47+0000
committerVincent Ambo <tazjin@google.com>2020-02-21T13·54+0000
commit4bbbb58cb537014dd8b0b3c3c560c039ac57ad89 (patch)
treeffd6c2c6758f655801ea6497b3dd9d2f2d04ebc9 /overrides/default.nix
parent5d9d84f4cfdbed049e71ce6f15bb1ad8650f7acf (diff)
chore: Rename pkgs->depot in all Nix file headers r/559
Diffstat (limited to 'overrides/default.nix')
-rw-r--r--overrides/default.nix21
1 files changed, 3 insertions, 18 deletions
diff --git a/overrides/default.nix b/overrides/default.nix
index 2159d45bd0..8bc49dec47 100644
--- a/overrides/default.nix
+++ b/overrides/default.nix
@@ -1,28 +1,13 @@
 # This file is used to move things from nested attribute sets to the
 # top-level.
-{ pkgs, ... }:
+{ depot, ... }:
 
 {
-  buildGo = pkgs.nix.buildGo;
-
-  # These packages must be exposed at the top-level for compatibility
-  # with Nixery.
-  inherit (pkgs.third_party)
-    bashInteractive
-    cacert
-    coreutils
-    iana-etc
-    jq
-    moreutils
-    nano
-    openssl
-    runCommand
-    symlinkJoin
-    writeText;
+  buildGo = depot.nix.buildGo; # TODO(tazjin): remove this
 
   # These packages must be exposed for compatibility with buildGo.
   #
   # Despite buildGo being tracked in this tree, I want it to be possible
   # for external users to import it with the default nixpkgs layout.
-  inherit (pkgs.third_party) go ripgrep;
+  inherit (depot.third_party) go ripgrep;
 }