about summary refs log tree commit diff
path: root/overrides/buildGo/example/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T20·18+0000
commit03bfe08e1dd9faf48b06cb146bfa446575cde88a (patch)
tree55317968922a9b2a01516f1b79527874df037517 /overrides/buildGo/example/default.nix
parente52eed3cd4f73779c2e7c350537fb346835ba9f3 (diff)
chore: Significantly restructure folder layout r/237
This moves the various projects from "type-based" folders (such as
"services" or "tools") into more appropriate semantic folders (such as
"nix", "ops" or "web").

Deprecated projects (nixcon-demo & gotest) which only existed for
testing/demonstration purposes have been removed.

(Note: *all* builds are broken with this commit)
Diffstat (limited to 'overrides/buildGo/example/default.nix')
-rw-r--r--overrides/buildGo/example/default.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/overrides/buildGo/example/default.nix b/overrides/buildGo/example/default.nix
deleted file mode 100644
index 5abed1fbbcb5..000000000000
--- a/overrides/buildGo/example/default.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2019 Google LLC.
-# SPDX-License-Identifier: Apache-2.0
-
-# This file provides examples for how to use the various builder
-# functions provided by `buildGo`.
-#
-# The features used in the example are not exhaustive, but should give
-# users a quick introduction to how to use buildGo.
-
-let
-  buildGo = import ../buildGo.nix {};
-
-  # Example use of buildGo.package, which creates an importable Go
-  # package from the specified source files.
-  examplePackage = buildGo.package {
-    name = "example";
-    srcs = [
-      ./lib.go
-    ];
-  };
-
-  # Example use of buildGo.proto, which generates a Go library from a
-  # Protobuf definition file.
-  exampleProto = buildGo.proto {
-    name = "exampleproto";
-    proto = ./thing.proto;
-  };
-
-  # Example use of buildGo.program, which builds an executable using
-  # the specified name and dependencies (which in turn must have been
-  # created via buildGo.package etc.)
-in buildGo.program {
-  name = "example";
-
-  srcs = [
-    ./main.go
-  ];
-
-  deps = [
-    examplePackage
-    exampleProto
-  ];
-
-  x_defs = {
-    "main.Flag" = "successfully";
-  };
-}