about summary refs log tree commit diff
path: root/ops/nixos/www/b.tvl.fyi.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-11T20·50+0200
committertazjin <mail@tazj.in>2021-04-11T22·18+0000
commit90281c4eac4cd25045ed80c5f8f27c74898a02b3 (patch)
tree804425642af16b9e299d469ad6e21c6a23a400e9 /ops/nixos/www/b.tvl.fyi.nix
parent7deabb8c8d6f4c7e58e2b16548b8a1895795963b (diff)
refactor(ops): Split //ops/nixos into different locations r/2482
Splits //ops/nixos into:

* //ops/nixos.nix - utility functions for building systems
* //ops/machines - shared machine definitions (read by readTree)
* //ops/modules - shared NixOS modules (skipped by readTree)

This simplifies working with the configuration fixpoint in whitby, and
is overall a bit more in line with how NixOS systems in user folders
currently work.

Change-Id: I1322ec5cc76c0207c099c05d44828a3df0b3ffc1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2931
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'ops/nixos/www/b.tvl.fyi.nix')
-rw-r--r--ops/nixos/www/b.tvl.fyi.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/ops/nixos/www/b.tvl.fyi.nix b/ops/nixos/www/b.tvl.fyi.nix
deleted file mode 100644
index 45f6c6ed5141..000000000000
--- a/ops/nixos/www/b.tvl.fyi.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ config, ... }:
-
-{
-  imports = [
-    ./base.nix
-  ];
-
-  config = {
-    services.nginx.virtualHosts."b-shortlink" = {
-      serverName = "b";
-      extraConfig = "return 302 https://b.tvl.fyi$request_uri;";
-    };
-
-    services.nginx.virtualHosts."b.tvl.fyi" = {
-      serverName = "b.tvl.fyi";
-      serverAliases = [ "b.tvl.su" ];
-      enableACME = true;
-      forceSSL = true;
-
-      extraConfig = ''
-        # Forward short links to issues to the issue itself (b/32)
-        location ~ ^/(\d+)$ {
-          return 302 https://b.tvl.fyi/issues$request_uri;
-        }
-
-        location / {
-          proxy_pass http://localhost:${toString config.services.depot.panettone.port};
-        }
-      '';
-    };
-  };
-}