about summary refs log tree commit diff
path: root/ops/nixos/tvl-slapd/default.nix
diff options
context:
space:
mode:
authorLuke Granger-Brown <git@lukegb.com>2021-04-02T12·18+0000
committerlukegb <lukegb@tvl.fyi>2021-04-02T18·00+0000
commitb35e358eb5841b62caa8408ce2dbee105bf8d9c8 (patch)
treeb8d00a42560ee0567bb663c8fd65b5dd7d796e83 /ops/nixos/tvl-slapd/default.nix
parent999f98436cf854d360269368f61a498e506167a4 (diff)
refactor(ops/nixos): migrate to depot module arg r/2407
Previously the depot argument was provided as config.depot, but the "new
way" of doing things (which is more like the args list provided in the
rest of the depot) is to provide this as the "depot" NixOS module
argument instead.

Change-Id: Ib48b1c7c1bdff9c1eb0618c6cbacc22b651f5f98
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2763
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'ops/nixos/tvl-slapd/default.nix')
-rw-r--r--ops/nixos/tvl-slapd/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/ops/nixos/tvl-slapd/default.nix b/ops/nixos/tvl-slapd/default.nix
index d32bc96b83..ae99fced74 100644
--- a/ops/nixos/tvl-slapd/default.nix
+++ b/ops/nixos/tvl-slapd/default.nix
@@ -1,9 +1,9 @@
 # Configures an OpenLDAP instance for TVL
 #
 # TODO(tazjin): Configure ldaps://
-{ config, lib, pkgs, ... }:
+{ depot, lib, pkgs, ... }:
 
-with config.depot.nix.yants;
+with depot.nix.yants;
 
 let
   user = struct {
@@ -24,7 +24,7 @@ let
     userPassword: ${u.password}
   '');
 
-  inherit (config.depot.ops) users;
+  inherit (depot.ops) users;
 
 in {
   # Use our patched OpenLDAP derivation which enables stronger password hashing.
@@ -34,7 +34,7 @@ in {
   # *large* number of rebuilds of packages such as GPG and Python.
   nixpkgs.overlays = [
     (_: _: {
-      inherit (config.depot.third_party) openldap;
+      inherit (depot.third_party) openldap;
     })
   ];