about summary refs log tree commit diff
path: root/ops/nixos/tvl-buildkite.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-10T11·40+0200
committertazjin <mail@tazj.in>2021-04-10T12·09+0000
commit9c5b5600ea3e8916af5715185ef57e57f36cf82b (patch)
tree0342084d593bb5a672bc3764655c517ce3d007fc /ops/nixos/tvl-buildkite.nix
parentd62fab4168129180e964a02a5a72c91623d1b962 (diff)
refactor(ops): Consistent use of depot.third_party vs. pkgs r/2464
In preparation for the solution of b/108, we need to consistently use
`depot.third_party` for packages that are only packed in the TVL depot
and `pkgs` for things that come from nixpkgs.

This commit cleans up a huge chunk of these uses in //ops

Change-Id: I00faeb969eaa70760a26256274925b07998c2351
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2915
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'ops/nixos/tvl-buildkite.nix')
-rw-r--r--ops/nixos/tvl-buildkite.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/ops/nixos/tvl-buildkite.nix b/ops/nixos/tvl-buildkite.nix
index 4ea92b6eea..c6dcbd3bc1 100644
--- a/ops/nixos/tvl-buildkite.nix
+++ b/ops/nixos/tvl-buildkite.nix
@@ -1,5 +1,5 @@
 # Configuration for the TVL buildkite agents.
-{ config, depot, lib, ... }:
+{ config, depot, pkgs, lib, ... }:
 
 let
   cfg = config.services.depot.buildkite;
@@ -8,7 +8,7 @@ let
 
   # All Buildkite hooks are actually besadii, but it's being invoked
   # with different names.
-  buildkiteHooks = depot.third_party.runCommandNoCC "buildkite-hooks" {} ''
+  buildkiteHooks = pkgs.runCommandNoCC "buildkite-hooks" {} ''
     mkdir -p $out/bin
     ln -s ${depot.ops.besadii}/bin/besadii $out/bin/post-command
   '';