about summary refs log tree commit diff
path: root/ops/nixos/quassel.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-11T20·50+0200
committertazjin <mail@tazj.in>2021-04-11T22·18+0000
commit90281c4eac4cd25045ed80c5f8f27c74898a02b3 (patch)
tree804425642af16b9e299d469ad6e21c6a23a400e9 /ops/nixos/quassel.nix
parent7deabb8c8d6f4c7e58e2b16548b8a1895795963b (diff)
refactor(ops): Split //ops/nixos into different locations r/2482
Splits //ops/nixos into:

* //ops/nixos.nix - utility functions for building systems
* //ops/machines - shared machine definitions (read by readTree)
* //ops/modules - shared NixOS modules (skipped by readTree)

This simplifies working with the configuration fixpoint in whitby, and
is overall a bit more in line with how NixOS systems in user folders
currently work.

Change-Id: I1322ec5cc76c0207c099c05d44828a3df0b3ffc1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2931
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'ops/nixos/quassel.nix')
-rw-r--r--ops/nixos/quassel.nix76
1 files changed, 0 insertions, 76 deletions
diff --git a/ops/nixos/quassel.nix b/ops/nixos/quassel.nix
deleted file mode 100644
index df26a3945532..000000000000
--- a/ops/nixos/quassel.nix
+++ /dev/null
@@ -1,76 +0,0 @@
-# A more modern module for running Quassel.
-{ config, lib, pkgs, ... }:
-
-let
-  cfg = config.services.depot.quassel;
-  quasselDaemon = pkgs.quassel.override {
-    monolithic = false;
-    enableDaemon = true;
-    withKDE = false;
-  };
-in {
-  options.services.depot.quassel = with lib; {
-    enable = mkEnableOption "Quassel IRC daemon";
-
-    acmeHost = mkOption {
-      description = "ACME host to use for the Quassel TLS certificate";
-      type = lib.types.str;
-    };
-
-    bindAddresses = mkOption {
-      description = "Addresses Quassel will bind to/listen on";
-      default = [ "127.0.0.1" ];
-    };
-
-    logLevel = mkOption {
-      description = "Log level for Quassel Core";
-      default = "Info";
-      type = lib.types.enum [
-        "Debug"
-        "Info"
-        "Warning"
-        "Error"
-      ];
-    };
-
-    port = mkOption {
-      default = 6698;
-      description = ''
-        The port number the Quassel daemon will be listening to.
-      '';
-    };
-  };
-
-  config = with lib; mkIf cfg.enable {
-    systemd.services.quassel = {
-      description = "Quassel IRC daemon";
-      wantedBy = [ "multi-user.target" ];
-
-      script = concatStringsSep " " [
-        "${quasselDaemon}/bin/quasselcore"
-        "--listen=${concatStringsSep "," cfg.bindAddresses}"
-        "--port=${toString cfg.port}"
-        "--configdir=/var/lib/quassel"
-        "--require-ssl"
-        "--ssl-cert=/var/lib/acme/${cfg.acmeHost}/full.pem"
-        "--loglevel=${cfg.logLevel}"
-      ];
-
-      serviceConfig = {
-        Restart = "always";
-        User = "quassel";
-        Group = "quassel";
-        StateDirectory = "quassel";
-      };
-    };
-
-    users = {
-      users.quassel = {
-        isNormalUser = false;
-        group = "quassel";
-      };
-
-      groups.quassel = {};
-    };
-  };
-}