about summary refs log tree commit diff
path: root/ops/nixos/nugget/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <Vincent Ambo>2020-01-19T01·44+0000
committerVincent Ambo <Vincent Ambo>2020-01-19T01·44+0000
commit89b0a437861fd2553afec18c574dfa894aa77bc6 (patch)
treee1173c44812d51672121ad71a3394cbdc092e4eb /ops/nixos/nugget/default.nix
parentd05489adaa5e1888b9b8ed76aa9a8a05ebf51f2e (diff)
feat(ops/nixos/nugget): Connect to wifi & install Google Chrome r/416
This adds configuration which, sometimes, when the stars align just
right, makes it possible to cast to the Chromecast from nugget.
Diffstat (limited to '')
-rw-r--r--ops/nixos/nugget/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/ops/nixos/nugget/default.nix b/ops/nixos/nugget/default.nix
index ca0e7f1c22..735b02e008 100644
--- a/ops/nixos/nugget/default.nix
+++ b/ops/nixos/nugget/default.nix
@@ -55,7 +55,16 @@ in pkgs.lib.fix(self: {
     ];
 
     # Open Chromecast-related ports & servedir
+    firewall.enable = false;
     firewall.allowedTCPPorts = [ 4242 5556 5558 ];
+
+    # Connect to the WiFi to let the Chromecast work.
+    wireless.enable = true;
+    wireless.networks = {
+      "How do I computer?" = {
+        psk = "washyourface";
+      };
+    };
   };
 
   # Generate an immutable /etc/resolv.conf from the nameserver settings
@@ -91,6 +100,7 @@ in pkgs.lib.fix(self: {
       fd
       gnupg
       go
+      google-chrome
       google-cloud-sdk
       htop
       imagemagick