about summary refs log tree commit diff
path: root/ops/nixos/modules/smtprelay.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-06-13T20·52+0100
committertazjin <mail@tazj.in>2020-06-13T23·52+0000
commit268729083eb80c93aa402883085c37e32c8a08cf (patch)
tree0916bace8073d30976ec752bb9de8c19a06027ae /ops/nixos/modules/smtprelay.nix
parent9658e96a87178e972b656db0acf3219937013b88 (diff)
refactor(ops/nixos): Move my NixOS configurations to //users/tazjin r/941
NixOS modules move one level up because it's unlikely that //ops/nixos
will contain actual systems at this point (they're user-specific).

This is the first users folder, so it is also added to the root
readTree invocation for the repository.

Change-Id: I546c701145fa204b7ba7518a8a56a783588629e0
Reviewed-on: https://cl.tvl.fyi/c/depot/+/244
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'ops/nixos/modules/smtprelay.nix')
-rw-r--r--ops/nixos/modules/smtprelay.nix52
1 files changed, 0 insertions, 52 deletions
diff --git a/ops/nixos/modules/smtprelay.nix b/ops/nixos/modules/smtprelay.nix
deleted file mode 100644
index ca960f5190a8..000000000000
--- a/ops/nixos/modules/smtprelay.nix
+++ /dev/null
@@ -1,52 +0,0 @@
-# NixOS module for configuring the simple SMTP relay.
-{ pkgs, config, lib, ... }:
-
-let
-  inherit (builtins) attrValues mapAttrs;
-  inherit (lib)
-    concatStringsSep
-    mkEnableOption
-    mkOption
-    types
-;
-
-  cfg = config.services.depot.smtprelay;
-  description = "Simple SMTP relay";
-
-  # Configuration values that are always overridden. In particular,
-  # `config` is specified to always load $StateDirectory/secure.config
-  # (so that passwords can be loaded from there) and logging is pinned
-  # to stdout for journald compatibility.
-  overrideArgs = {
-    logfile = "";
-    config = "/var/lib/smtprelay/secure.config";
-  };
-
-  # Creates the command line argument string for the service.
-  prepareArgs = args:
-    concatStringsSep " "
-      (attrValues (mapAttrs (key: value: "-${key} '${toString value}'")
-                            (args // overrideArgs)));
-in {
-  options.services.depot.smtprelay = {
-    enable = mkEnableOption description;
-    args = mkOption {
-      type = types.attrsOf types.str;
-      description = "Key value pairs for command line arguments";
-    };
-  };
-
-  config = {
-    systemd.services.smtprelay = {
-      inherit description;
-      script = "${config.depot.third_party.smtprelay}/bin/smtprelay ${prepareArgs cfg.args}";
-      wantedBy = [ "multi-user.target" ];
-
-      serviceConfig = {
-        Restart = "always";
-        StateDirectory = "smtprelay";
-        DynamicUser = true;
-      };
-    };
-  };
-}